Как установить Ruby 2.1.4 на Ubuntu 14.04

100

Я не знаю, как установить последнюю версию Ruby на Ubuntu.

Сначала я установил по умолчанию Ruby 1.9.3, используя

sudo apt-get install ruby

Затем я попытался установить версию 2.0 с помощью

sudo apt-get install ruby2.0

Моя версия Ruby по-прежнему "ruby 1.9.3p484 (версия 2013-11-22 версия 43786) [x86_64-linux])"

Что мне делать?

  • 0
    Этот ответ был очень полезен для установки менеджера версий ruby, который позволяет вам извлекать и использовать любую версию, которую вы хотите, когда вы хотите в своей домашней среде без необходимости использования sudo
Теги:
ubuntu-14.04

5 ответов

124
Лучший ответ

Прежде всего, установите необходимые библиотеки:

sudo apt-get update
sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties libffi-dev

Затем установите rbenv, который используется для установки Ruby:

cd
git clone https://github.com/rbenv/rbenv.git ~/.rbenv
echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bashrc
echo 'eval "$(rbenv init -)"' >> ~/.bashrc
exec $SHELL

git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build
echo 'export PATH="$HOME/.rbenv/plugins/ruby-build/bin:$PATH"' >> ~/.bashrc
exec $SHELL

rbenv install 2.3.1
rbenv global 2.3.1
ruby -v

Затем (необязательно) скажите Rubygems не устанавливать локальную документацию:

echo "gem: --no-ri --no-rdoc" > ~/.gemrc

Кредиты: https://gorails.com/setup/ubuntu/14.10

Внимание!!! Существуют проблемы с Gnome-Shell. См. Комментарий ниже.

  • 0
    Стоит отметить, что пользователю может потребоваться выполнить следующую команду перед установкой ruby 2.2.0 sudo apt-get install libffi-dev
  • 0
    @ThaDick спасибо, обновленный ответ
Показать ещё 8 комментариев
174

Существует PPA с обновленными версиями Ruby 2.x для Ubuntu 12.04 +:

$ sudo apt-add-repository ppa:brightbox/ruby-ng
$ sudo apt-get update
$ sudo apt-get install ruby2.4

$ ruby -v
ruby 2.4.1p111 (2017-03-22 revision 58053) [x86_64-linux-gnu]
  • 5
    Мне удалось установить Ruby 2.3 с помощью репозитория brightbox. Спасибо
  • 7
    Гениально !! Работает на Ubuntu 14.04
Показать ещё 5 комментариев
38

Лучше всего установить его с помощью rvm (рубиновый менеджер версий).
Выполните следующие команды в терминале:

sudo apt-get update
sudo apt-get install build-essential make curl
\curl -L https://get.rvm.io | bash -s stable
source ~/.bash_profile
rvm install ruby-2.1.4

Затем проверьте установленные и используемые рубиновые версии:

rvm list
rvm use --default ruby-2.1.4

Также вы можете напрямую добавить путь Ruby bin к переменной PATH. Ruby установлен в

$HOME/.rvm/rubies export PATH=$PATH:$HOME/.rvm/rubies/ruby-2.1.4/bin
  • 10
    Пропускать произвольный код по сети - плохая идея. Вот «Стена позора», показывающая оскорбительные сайты: curlpipesh.tumblr.com
  • 2
    Отсутствует загрузка открытого ключа, см. Rvm.io
Показать ещё 2 комментария
6

Используйте RVM (Ruby Version Manager) для установки и управления любыми версиями Ruby. На компьютере можно установить несколько версий Ruby, и вы можете легко выбрать тот, который вам нужен.

Чтобы установить RVM-тип в терминал:

\curl -sSL https://get.rvm.io | bash -s stable

И пусть это сработает. После этого у вас будет RVM вместе с Ruby.

Источник: Сайт RVM

  • 1
    Чтобы установить RVM, следуйте инструкциям на их странице установки . Использование RVM намного шире, чем запуск cURL, и страница установки выходит за рамки этого. Его следует прочитать перед установкой, чтобы ознакомиться с его действиями, включая действия по устранению неполадок.
  • 0
    @theTinMan Конечно, я полностью с тобой согласен. Вот почему я добавил их страницу в качестве источника, чтобы автор этой темы мог прочитать больше об этом.
Показать ещё 2 комментария
3

обновить ubuntu:

 sudo apt-get update
 sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties libffi-dev

Установите rvm, который управляет рубиновыми версиями:

для установки rvm используйте следующую команду.

 \curl -sSL https://get.rvm.io | bash -s stable
 source ~/.bash_profile
 rvm install ruby-2.1.4

Проверьте версии и используемые рубиновые версии:

rvm list
rvm use --default ruby-2.1.4
Сообщество Overcoder
Наверх
Меню